Access via OMERO.insight but not omero web

I managed to install omero and omero web on centos 7. If I use insight, I can login with both the root account and other created. However, using omero web, after entering the credentials and clicking login, the page just refresh to its default (not even wrong password message it displays; if wrong credentials are inserted the message displays).
I tried to look into the log files to identify the problem without success.

OMERO.server/bin/omero config get:

OMERO.server/bin/omero admin diagnostics

OMERO Diagnostics (admin) 5.5.1-ice36-b122
Commands:   java -version                  1.8.0     (/bin/java)
Commands:   python -V                      2.7.5     (/bin/python)
Commands:   icegridnode --version          3.6.5     (/bin/icegridnode)
Commands:   icegridadmin --version         3.6.5     (/bin/icegridadmin)
Commands:   psql --version                 10.10     (/bin/psql)
Commands:   openssl version                1.0.2     (/bin/openssl)

Server:     icegridnode                    running
Server:     Blitz-0                        active (pid = 161576, enabled)
Server:     DropBox                        active (pid = 162695, enabled)
Server:     FileServer                     active (pid = 161605, enabled)
Server:     Indexer-0                      active (pid = 161611, enabled)
Server:     MonitorServer                  active (pid = 161612, enabled)
Server:     OMERO.Glacier2                 active (pid = 161618, enabled)
Server:     OMERO.IceStorm                 active (pid = 161619, enabled)
Server:     PixelData-0                    active (pid = 161620, enabled)
Server:     Processor-0                    active (pid = 161621, enabled)
Server:     Tables-0                       active (pid = 161637, enabled)
Server:     TestDropBox                    inactive (enabled)

Log dir:    /home/omero/OMERO.server/var/log exists
Log files:  Blitz-0.log                    225.0 KB      errors=18   warnings=4   
Log files:  DropBox.log                    2.0 KB        errors=2    warnings=1   
Log files:  FileServer.log                 114 B        
Log files:  Indexer-0.log                  5.0 KB        errors=0    warnings=3   
Log files:  MonitorServer.log              1.0 KB       
Log files:  OMEROweb.lock                  empty
Log files:  OMEROweb.log                   5.0 KB        errors=0    warnings=1   
Log files:  PixelData-0.log                2.0 KB        errors=0    warnings=2   
Log files:  Processor-0.log                977 B        
Log files:  Tables-0.log                   1.0 KB       
Log files:  TestDropBox.log                n/a
Log files:  master.err                     34.0 KB       errors=1    warnings=0   
Log files:  master.out                     empty
Log files:  Total size                     0.28 MB


OMERO SSL port:4064                           
OMERO TCP port:4063                           
OMERO data dir:'/OMERO'                       Exists? True	Is writable? True
OMERO temp dir:'/home/omero/omero/tmp'        Exists? True	Is writable? True   (Size: 0)

JVM settings: Blitz-${index}                -Xmx590m -XX:MaxPermSize=256m -XX:+IgnoreUnrecognizedVMOptions
JVM settings: Indexer-${index}              -Xmx393m -XX:MaxPermSize=256m -XX:+IgnoreUnrecognizedVMOptions
JVM settings: PixelData-${index}            -Xmx590m -XX:MaxPermSize=256m -XX:+IgnoreUnrecognizedVMOptions
JVM settings: Repository-${index}           -Xmx393m -XX:MaxPermSize=256m -XX:+IgnoreUnrecognizedVMOptions

OMERO.server/bin/omero web diagnostics

OMERO Diagnostics (web) 5.5.1-ice36-b122
OMERO.web status... [RUNNING] (PID 158100)
Django version: 1.8.19

Log dir:    /home/omero/OMERO.server/var/log exists
Log file :  OMEROweb.log                   5.0 KB        errors=0    warnings=1

You’ve turned on the session cache omero.web.session_engine=django.contrib.sessions.backends.cache but you haven’t provided the cache backend:

Thank you, problem solved. I dropped the configuration and have done it again without the cache items and it is working fine. I will configure this later.