3D Viewer stopped working

3d-viewer
imagej

#1

Hi, I’ve been using ImageJ 1.51s with 3D Viewer for some time now. After some system updates, I can’t start the plugin anymore. The following error message is shown in the log:

java.lang.InternalError: XXX0 profile[1]: GL3bc -> profileImpl GL4bc !!! not mapped 
at com.jogamp.opengl.GLProfile.computeProfileMap(GLProfile.java:2071)
at com.jogamp.opengl.GLProfile.initProfilesForDeviceCritical(GLProfile.java:1954)
at com.jogamp.opengl.GLProfile.initProfilesForDevice(GLProfile.java:1875)
at com.jogamp.opengl.GLProfile.initProfilesForDefaultDevices(GLProfile.java:1842)
at com.jogamp.opengl.GLProfile.access$000(GLProfile.java:80)
at com.jogamp.opengl.GLProfile$1.run(GLProfile.java:230)
at java.security.AccessController.doPrivileged(Native Method)
at com.jogamp.opengl.GLProfile.initSingleton(GLProfile.java:216)
at com.jogamp.opengl.GLProfile.getProfileMap(GLProfile.java:2297)
at com.jogamp.opengl.GLProfile.get(GLProfile.java:1021)
at com.jogamp.opengl.GLProfile.get(GLProfile.java:1050)
at com.jogamp.opengl.GLProfile.getMaxFixedFunc(GLProfile.java:803)
at org.scijava.java3d.JoglPipeline.initialize(JoglPipeline.java:132)
at org.scijava.java3d.Pipeline.createPipeline(Pipeline.java:92)
at org.scijava.java3d.MasterControl.loadLibraries(MasterControl.java:837)
at org.scijava.java3d.VirtualUniverse.<clinit>(VirtualUniverse.java:274)
at ij3d.ImageJ3DViewer.run(ImageJ3DViewer.java:60)
at ij3d.ImageJ_3D_Viewer.run(ImageJ_3D_Viewer.java:37)
at ij.IJ.runUserPlugIn(IJ.java:221)
at ij.IJ.runPlugIn(IJ.java:185)
at ij.Executer.runCommand(Executer.java:137)
at ij.Executer.run(Executer.java:66)
at java.lang.Thread.run(Thread.java:745)

I have read in other threads about newer Java versions causing problems with 3D Viewer. Typing java -version in a terminal gives me:

openjdk version "1.8.0_151"
OpenJDK Runtime Environment (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12)
OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode)

#2

Just to make sure: is this the java version that ImageJ actually uses?

What is the version reported by ImageJ itself when clicking the status bar?


#3

Hi Jan, in the status bar it says Java 1.8.0_66 [64-bit]. So is this actually Java 8? These version numbers confuse me…


#4

Hi there,

Did you find a solution by any chance?
I get the same issue. I upgraded to Ubuntu 16.04 and when I open the Fiji plugin “3D viewer” this window pops up


#5

Hi Chlochou, I haven’t found a solution. For any 3D visualization I’ve switched to ParaView for now. If you want to try that, this might help: http://wiki.rac.manchester.ac.uk/community/ParaView/Tips/LoadImageStack


#6

Dear @chlochou,

could you try to run Plugins > 3D Viewer again with a fresh Fiji installation? Do you still experience the issue?

Best,
Stefan


#7

Hi,

Thanks a lot for your ideas.

I would like to use ImageJ so I don’t try Para View for now, but I keep this option in mind.

The fresh Fiji installation didn’t make the 3D Viewer work.

Forcing Ubuntu 16.04 to use the NVIDIA proprietary driver and not the open access one was a solution in order not to get the error message when opening 3D Viewer.
Go to Software & Updates -> Additional Drivers

Thanks again for your help and ideas,

Cheers

Chloe


#8

I have the exact same problem, I am also using Ubuntu 16.04 and the problem started “out of the blue”. Probably after updating a package related to the video drivers.


#9

Just to make sure folks are aware, you can use SciView for 3D visualization in ImageJ on Ubuntu 16.04 (at least with the proprietary Nvidia drivier).


#10

Hi @kephale I tried to use SciView, unfortunately it does not work and throws exceptions to all operations, including demos.

It is probably related with the graphic driver problem we seem to have, and not be caused by the plugin itself.


#11

If you could tell us the driver and post a log of the exceptions that you’re getting, then we will try to get SciVIew working for you. This is good timing because we have a SciView update scheduled for next week.

In general, folks are more excited to get SciView working on all systems than maintaining the older 3D viewer package that will inevitably suffer from more bitrot in the future.