3d mouse support

In the QuPath wiki 3D mouse support is mentioned. What’s up with this? When clicking on the provided extension link nothing happens, some unauthorized error dropped. We would like to use a SpaceMouse product.

Thanks in advance, Alex

If you are referring to the link here:


The problem was just that the hyperlink doesn’t go to the same place as the link describes. Copying and pasting the link into a browser worked for me to get to the code.

Good luck! Never used one, but the idea seems cool, even if it was limited to only Macs (and looks like it was last updated a year ago, so might not work with the newer releases).

Edit* I also don’t see any listing under the Extensions, so I’m not sure where the extension itself might be.

I’m afraid 3D mouse support has been dropped after v0.1.2 for three main reasons:

  • I don’t have a 3D mouse myself to test anything with…
  • after using it successfully with one 3D mouse years ago, a later tried it with a more recent model… and it didn’t work
  • I didn’t think the jinput project was very active any more (maybe now it is?), and since it requires native libraries it is rather more awkward to package up in QuPath than Java-only code

If you are interested in it, you could try adapting the qupath-extension-input module code from v0.1.2 here to bring it up to date.

1 Like

Actually we are using v0.1.2 right no, so the quapth-extension-input module would be fine if it allows the use of a 3D mouse. If I am not mistaken, then I should just jar the module and I can drag and drop it to the extensions?

In that case it should work if you select the 3D mouse support option in the QuPath preferences - you may need to have the mouse connected when doing this (adding it later isn’t sufficient).

Whether it does work is another matter… I recall having success with an older model, but not with a newer one. But this was some years ago and I’m afraid I don’t remember specifics…