3D Error With .lif and ome.tif files



Hi, can you please help me figure out how to use CP v3 for 3D data sets when using .lif files.

I’m not sure how to deal with the 3D aspect, and if I need to change anything subtle to get it to know which images are part of the same stack. I had some errors, so I decided to start simple. I saved a .lif file with a single zstack with 3 chns, and only pulled chn 0, then added a primary object. See cp file here: nuc_lif_single_fail.cpproj (672.9 KB)
See here for the single zstack lif: https://www.amazon.com/clouddrive/share/VFrJ9PlKmNgpfz78dCjCCZjt2ESv23pDn8D27q3wBGd

When I try to use the test mode it errors informing me that the NamesAndTypes has an error of None…?

I tried exporting the image to \ome.tifs for each chn with Bioformats in Fiji, see cp file here:nuc_ometif_fail.cpproj (673.3 KB) and it let’s me start the test mode but on stepping it errors in IdentifyingPrimaryObjects: The None image is missing from the pipeline
ometif file here: https://www.amazon.com/clouddrive/share/gOFippBfCvgJ10OU051Zoe9eRbM9ZZVNsoySrxNGYSS

Any clues would be much appreciated. I’d love to see how the 3D segmentation works out :slight_smile:



Hi Neil,

AFAIK, 3D only works with TIFs where all Z planes are in the same TIF but channels are separate- i.e. if you had 3 channels with 20 planes, you’d have 3 TIFs with 20 planes each. Can you try that and see if it works for you?


Hi Beth, thanks for the speedy reply as always :slight_smile:
I tried with the ome tif, but I’ll try again with a standard tif saved from Fiji and see how that goes.
Thanks for the tip.