32bit float images in CellProfiler - can't seem to be able to import

Hi,
I want to input deconvolved images (32bit float tifs) into CellProfiler for my analysis pipeline but somehow it doesn’t seem to work and I can’t find the issue.
Images are originally ics files output from huygens. Then I wrote an imageJ macro to max project them and save them as a 4-ch tif (specifying the display ranges for ease of use). I can open them fine on Fiji (so I guess BioFormats works).
I input htem in the pipeline and the metadata extraction + regex works and recognizes that there are 4 channels and 1Z
But when I want to run the NamesAndTypes module and assign channel names it doesnt work --> “Your pipeline doesn’t produce any valid image sets as currently configured”
Any ideas? or should I force the 16bit conversion?
am a bit worried about how the rescaling will work in case of 32bit float images (what max will CP use?)

Fiji Min/Max information on each channel

Fiji Informtion output on the images

 
Title: 20201119_514_UNTR_Rep2_02_cmle_Max.tif
Width:  81.92 microns (1024)
Height:  81.92 microns (1024)
Size:  16MB
Resolution:  12.5 pixels per micron
Voxel size: 0.08x0.08x0.262 micron^3
ID: -13
Bits per pixel: 32 (float)
Display ranges
  1: 0-35000
  2: 0-90000
  3: 0-80000
  4: 0-105000
Frame: 4/4
Frame interval: 1 sec
  Channels: 4
  Composite mode: "composite"
No threshold
Magnification: 0.75
ScaleToFit: false
Uncalibrated
Path: D:\_INPUT\WF_data\siLap2_siBAF_replicat1-2_decon\Untr_Replicat2_decon_Max\20201119_514_UNTR_Rep2_02_cmle_Max.tif
Screen location: 579,108 (1920x1200)
Coordinate origin:  0,0,0
No properties
No overlay
No selection

Metadata output

NamesAndTypes

But when I want to run the NamesAndTypes module and assign channel names it doesnt work --> “Your pipeline doesn’t produce any valid image sets as currently configured”

Do you see any errors appearing in the console when this happens?

nope none at all… generally this is where it tells me where i screwed up but it ontly shows “starting cellprofiler 4.0.6”

If you check the Images module, does clicking the ‘apply filters’ button make the image names grey out?

nope they are not greyed out - also the metadata wouldn’t populate then, right?
I tried multiple variation on this and it doesnt work (opening ics file in fiji, Z projecting saving as ics or tif 32bit, both don’t work). I can open the ICS file in CellProfiler (though 3D) but I have never worked with 3D images… I can upload one in case you want to test - will try more tomorrow!

test32bitCrop.zip (4.2 MB)

Hi @Debora_KellerOlivier,

I just tried your 32 bit images in CP4.0.6. It works fine. I tried all the three images in the zip file & also tried adding a module, it works for all with the four channels.

Regards,
Lakshmi

ok could you maybe send the mini pipeline you are using ie just the import modules?
Cheers

Debbi

This pipeline seems to have no trouble with the tif file as input. Did your metadata module definitely have ‘extract from file headers’ enabled and executed?

splitchannels.cppipe (5.1 KB)

Another approach here if you’re still having trouble is to declare these as color images and then run ColorToGrey to split the channels, instead of worrying about Metadata matching.

Hi @Debora_KellerOlivier,

PFA pipeline. I have added both ics & tif file. Its is perfectly working. Please consider the suggestion from @DStirling on executing Metadata.
ics_image_import.cpproj (1.0 MB)
Don’t forget to remove one of the image since both are same.

Regards,
Lakshmi

Hi guys, sorry for the delayed reply but just to say I have seen the posts and will check ASAP (just swamped at the microscope ATM) and reply on here to close the loop!

Hi both and happy new year!
it seems the grouping was causing the issue in my case (if removed it now and might come back to it later).
But thanks for the example pipeline which gave me a hint as to what was not working!
Cheers

Debbi