16-bit and 8-bit images

Dear cell profiler Staff,

i am now getting started with the cell profiler software.
I would like to analyze some images acquired with the Olympus Scan-R microscope. In order to analyze these 16bit images with cell profiler i used this pipeline:
Load images
Identify Primary Object
Measure Object Intensity
Export to spreadsheet
I tried it to few images in order to verify if all was working well. At the end of the analysis i observed that the window of the nuclei identification was weird (i attached it) and the nuclei mean intensity have always about the same values. When i converted the same images to an 8-bit format by using ImageJ, i obtained a more reasonable result. What does it mean? Do you think that i have to add some others modules to the pipeline in order to be able to analyze the 16bit images? Or in cell profiler i can analyze only 8 bit images?

Thanks,

Francesca

Hi Francesca,

CellProfiler should be able to handle both 8- or 16-bit images, and your pipeline sounds reasonable. However, your attachment didn’t get uploaded. Can you attach your *.cp pipeline file and an example input image, too?

Thanks,
David

Hi David,

here i am attaching two of the analyzed images, the pipeline and the weird windows of the nuclei identification (in the second post),

Thanks,

Francesca
test.cp (3.97 KB)



Hi David,
the pdf extension file is not supported. anyway in the window of nuclei identification the image is completely grey,

Thanks

Francesca

Hi Francesca,

I opened these images in CP2 and the 8- and 16-bit images looked similar. Note though, that CP auto-scales image intensities (for display only) and when I looked at their raw intensities, the images looked very different (See the attached screenshot):

The top plots are the 16-bit and the bottom, 8-bit. I right clicked on the images and chose “Raw” Image Contrast. The histograms show that the 16-bit intensities range from 0.50 to 0.57. I would check your scope settings to make sure you are maximizing your dynamic range

The bottom plots are the 8-bit, and these have apparently been autoscaled by ImageJ to range from 0 to 1. Unless you know the scaling factor, and you don’t care about measuring intensities (which your pipeline apparently does), we almost always suggest users not to auto scale their data. (For display, it’s safe)

Does this help?
Dave


Hi David,

Thanks for you very quick answers. The original 16 bit images have a dynamic range that is not maximized and it goes from about 33000 to 37000.
Do you think that i have to maximize the dynamic range (setting the minimum value to 0 and the maximum to 65536) of the 16 bit images and use them for the analysis instead of the 8bit images?

Thanks,

Francesca

The best solution would be to investigate why your microscope is outputting in this fashion, and try and maximize your dynamic range there. I suspect that it is really a 12-bit camera (common), whose output is being shifted up 2^15 by default, in which case you don’t need to change any scope settings. If this is true, then you would be safe in using ReascaleIntensity with the “specific values …custom range” setting to 0.5, 0.5625 remapped to 0,1. Whichever method you choose, ensure that the same transformation is being applied to all images equally.

David

Hi David,
in the microscope manual it is reported that “The camera has a bit depth of 12 so that saturation is reached at pixel values of 4095. However, the pictures are stored with 16 bit depth for reasons of computer efficiency.” I will try to add the module “Rescale Intensity”,
Thanks for your help,
Francesca

Hi Francesca,

That’s good confirmation. Plus it must add a left-most bit, shifting all values up by 32768. So yes, RescaleIntensity with the values I gave should work.

Best,
David